ARgh Knit Picks log in

:tap:Anyone else having an issue with logging onto the Knit Picks site?!?!?:tap:

I’m trying to complete a purchase and even though I’m entering the correct log in and password, it won’t let me check out!

Just curious if anyone else is experiencing this.:nails:

Yes - I get the same problem. I’ll actually be signed in, but when I try to check out it wants me to sign in again - then won’t accept it. This happens whenever I use a computer other than the one I initially enrolled on so I assume it has something to do with that (I’m not the best at understanding cookies, etc) as I can always check out if on the computer I originally used for my first sign in to the site when I registered.:shrug:

yup I’m signed in as well and can actually get into my account but nope can’t make my purchase! Have them accepted for cookies as well. I’ll try again later or just call in my order tomorow.
Thanks for replying!

yay it finally worked!! Don’t know what I did different but I finally placed my order!

I had that problem before when I first tried to use Knitpicks, but I e-mailed their support and in [I]a couple days[/I], they told me what to do to fix my browser. However, their website is always super slow for me. :frowning: :gah:

They’re lucky they have such awesome stuff!!! LOL

Yah no kidding hahaha. I ordered Clover yarn cutter and the KIper knitting bags(the black ones that come in a set of 5). Can’t wait!

Are you using Explorer? I sometimes have trouble unless I use Internet Explorer, then it always works.

It finally worked when I clicked on thier advertisment from this website. Yes I use IE.

I have the same thing happen to me. I have no choice but to call in my order whenever I want something. I thought it was just me (and that is what they told me) but now I know I’m not the only one. Hmm, I wonder if they know that more than one person experiences this issue.

urgh i had that same problem last week when i was trying to order some stuff!! i was at work when i was having the problem so i figured it had something to do with all of the security blocks we have on our computers. when i tried again at home, i didn’t have a problem. weird.